Author Topic: WTB: CR-200 series receiver (1950)  (Read 595 times)

Consoleman

  • Hero Member
  • *****
  • Posts: 696
  • Southeastern PA
    • View Profile
WTB: CR-200 series receiver (1950)
« on: July 18, 2016, 01:02:00 PM »
The tuner in mine is dead and I'm looking for another one to use for parts or just replace the whole thing. Looks like this, AM/FM/TV/Phono.



Mark

AlexanderMartin

  • Sr. Member
  • ****
  • Posts: 340
    • View Profile
Re: WTB: CR-200 series receiver (1950)
« Reply #1 on: July 18, 2016, 01:33:43 PM »
Power tranny dead?

Consoleman

  • Hero Member
  • *****
  • Posts: 696
  • Southeastern PA
    • View Profile
Re: WTB: CR-200 series receiver (1950)
« Reply #2 on: July 18, 2016, 02:42:46 PM »
No the amp works fine, but no signal passes through the tuner on AM or FM. I even took it to a nearby antique radio specialist and he wouldn't work on it without having another unit for parts.
Mark

Marv

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: WTB: CR-200 series receiver (1950)
« Reply #3 on: July 18, 2016, 03:04:37 PM »
What model CR-200 do you have?  There were models 200A thru D.  Nostalgia air has the schematic for the CR-200 series.  Have you done any trouble shooting such as voltage checks per the schematic, or check tubes?  What about the electrolytic and other caps?

I assume when you say the amp works that you can play the phono section, which excludes the front end of the chassis (tuners).

I have a CR-200E that I completely went thru a while back and it plays very nice. I did run into some SMD problems that I reported here in the repair section some time back (under CR-200E).

Consoleman

  • Hero Member
  • *****
  • Posts: 696
  • Southeastern PA
    • View Profile
Re: WTB: CR-200 series receiver (1950)
« Reply #4 on: July 18, 2016, 03:14:54 PM »
CR200-B. I've gone through it completely, recapped and even replaced all the resistors. All tube voltages in the tuner section are normal. The amp works well with Phono or TV inputs, and I put an external tuner on the TV input to fake it.
Maybe I'll start a repair thread.
Mark

AlexanderMartin

  • Sr. Member
  • ****
  • Posts: 340
    • View Profile
Re: WTB: CR-200 series receiver (1950)
« Reply #5 on: July 19, 2016, 02:14:50 PM »
Sounds like you got a miswired component or open IF coil, probably in the detector stages.