Author Topic: Skip and Repeat Blues Magnavox W750 Autochanger  (Read 319 times)

Heatproofboar

  • Newbie
  • *
  • Posts: 3
    • View Profile
Skip and Repeat Blues Magnavox W750 Autochanger
« on: December 29, 2016, 10:07:42 PM »
Had this console a couple months now and played and sounded perfect even rough looking lp's from the goodwill bin only pop a little.

Got a few new records for my wife for Christmas and they all skipped in the same place. Just as the control arm head passes the lead in grooves pic attached of spot it skips & repeats. This occurs around the 1 min mark, the dark spot around control arm is the phones shadow. 

Now any  lp I put on skips on this  same spot. If I use the cue lever to raise arm and move forward a bit the rest of it plays out fine.

Any theories on cause or troubleshooting advice welcome

Consoleman

  • Hero Member
  • *****
  • Posts: 696
  • Southeastern PA
    • View Profile
Re: Skip and Repeat Blues Magnavox W750 Autochanger
« Reply #1 on: December 30, 2016, 09:53:03 AM »
Did you put a new stylus on it? Also check the tracking force adjustment.

Something is binding, it probably could use a clean and lube underneath. There are some service manuals in the downloads section but I didn't see one for this specific unit.
Mark

Heatproofboar

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Skip and Repeat Blues Magnavox W750 Autochanger
« Reply #2 on: January 01, 2017, 06:08:56 PM »
Thanks for the advice. I ordered a new stylus and a force gauge today. Let ya know how it goes.   I think I found a Manual.