Author Topic: Need help with RP 205 problem  (Read 473 times)

gcmarsh43

  • Newbie
  • *
  • Posts: 8
    • View Profile
Need help with RP 205 problem
« on: January 03, 2018, 06:28:17 PM »
I am almost done with the resurrection of a 7 HF 4, and cannot resolve one remaining issue. The changer shuts off instead of playing the last record in a stack. I have adjusted the eccentric stud to drop the record as late as possible, but the stud (92b) has already passed under lever 38.

This poor baby has been out of action for a long time and I would like to give the owner (original) a fully functional player. So, is there a Guru for 205's that can offer a solution?

Thanks,

George

HiFiFun

  • Full Member
  • ***
  • Posts: 135
    • View Profile
Re: Need help with RP 205 problem
« Reply #1 on: January 05, 2018, 08:15:03 PM »
Hello George,

1. Can you give us details on what service you did
on the RP-205 ?

2. If you put on just one record on the spindle, does the
changer shut off after record drops ? (i.e. same problem
as you posted ?)

HiFiFun

gcmarsh43

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Need help with RP 205 problem
« Reply #2 on: January 06, 2018, 11:03:27 AM »
Hello HiFiFun,

Thanks for your help!!!

I have had the unit apart and cleaned and lubed it. It functions very well with the exception of the last record shut off. I have tried adjusting the eccentric to drop the record at the latest possible time, and have even tried shimming the stabilizer arm to stay off the trip lever until the last record drops, but all that does is allow the changer to replay the record instead of shutting off. It almost seems like the slide is not the correct one for the unit.

Would it be helpful to Skype to discuss?

George