Author Topic: Magnavox Micromatic Model: 2ST647 New Needle - No Sound  (Read 4336 times)

John B

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #30 on: March 24, 2018, 06:49:40 PM »
Steve,

I printed your last two post and I take them to the table where I have the chassis.  Do I plug it in while testing?  Also, I have a tester along with the meters but the part must be off the circuit board.  I'l try to start testing.

I have the chassis on the folding table and I plugged it in and turned it on and I got from the front to back:  11.2; -17.6; 17; 11.7. 

Attached picture shows what I tested on the opposite side.

John B


John B

SeniorSteve

  • Full Member
  • ***
  • Posts: 136
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #31 on: March 24, 2018, 07:20:48 PM »
Hi John, if you already have the chassis pulled, great!  If you have a multimeter, all I want to have you do is to check the voltage on the output transistors (the collector is connected to the case here) while the power is on.  Just connect one lead to the chassis and touch the other lead to each one of the output transistors.  The two inside transistors should have about 36 volts on them and the two outside transistors should have about 17 volts on them.  Make sure you are on the volts range of the multimeter.  The capacitor checker you show isn't needed at this time.  Depending on which way your leads are connected, it may say + voltage or - voltage.  I'm not concerned at the + -, I'm more concerned that you have half the supply voltage on the lower transistor.

John B

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #32 on: March 24, 2018, 07:40:25 PM »
Steve,

This time I checked from chassis to case. 
Front:  11.2
2nd:  28.9
3rd:  28.9
4th:  11.8

John B

SeniorSteve

  • Full Member
  • ***
  • Posts: 136
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #33 on: March 24, 2018, 07:54:53 PM »
That does look better than I thought.  With the chassis out of the cabinet, you probably do not have speakers on it.  Although the voltage is low, it shouldn't have caused you to have no, (or very little) sound.  Check all the resistors under the output transistors and see if any of them are bulging, the ones in particular are R88, R91, R104 and R107.  They are low in resistance value .39 ohm and they are larger.  The colors on them would be orange white gold silver.  If you have a speaker to connect, try connecting it to the speaker terminals on the chassis and see if you hear anything.  It doesn't matter which side you use.

SeniorSteve

  • Full Member
  • ***
  • Posts: 136
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #34 on: March 24, 2018, 07:57:58 PM »
One additional note on the resistors to check, the Sams shows two possible values, the second value if used would be a .47 ohm which is yellow violet gold silver.  Evidently Magnavox used both.

Steve

John B

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #35 on: March 24, 2018, 08:24:20 PM »
I found two Yellow-Violet-Gold-Silver.  They measured at 1.202 and 1.532 with the meter set at 2KVΩ.

John B

electra225

  • Hero Member
  • *****
  • Posts: 2482
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #36 on: March 24, 2018, 08:29:13 PM »
There is a driver transistor and push-pull output transistors, right?  We want to see 36 volts on one output transistor per channel and 17 volts on the other (on the case?).  I assume this is measured with respect to ground?  If an output transistor is shorted, weak audio may still appear in the speakers?  Is it typically expected that we would see shorted transistors in both channels?  Why would this be?  Due to the fact that the OP had his Pioneer receiver connected and it backfed the Magnavox amp somehow?
I don't need Google.  My wife says she knows everything.

SeniorSteve

  • Full Member
  • ***
  • Posts: 136
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #37 on: March 24, 2018, 08:42:23 PM »
John - Did the resistors look overheated?  Usually they crack in the center.    I'm going to go off on a tangent here.  The voltages aren't quite right, but if they (the output transistors) are conducting, the output transistors will be slightly warm, and the heatsink would be as well.  Can you check to see if there is any warmth  - it will be very slight.

Electra225 - That was what I was thinking, but the voltages are low on the bottom transistor, but not at zero.  If the output transistors shorted (and they usually do this collector to emitter), it opens up the emitter resistors (the .39 or .47 ohm ones).  What's confusing is the amount of voltage available at the bottom transistor collector, and especially the fact that they are very close.  I can't see that both output capacitors opened up at the same time.  I guess I should take a step back and find out how powerful the Pioneer receiver is, if it isn't a real high power model I might be chasing butterflies.  Bottom line is the radio, works but the amp does not.  I highly doubt the speakers are faulty.  Do you have any suggestions John might want to try? 

John B

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #38 on: March 24, 2018, 09:04:00 PM »
Steve,

The one that registered 1.101 does have something that looks like burn marks on the outside at one end.

John B

John B

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #39 on: March 24, 2018, 10:17:33 PM »
Steve,

Correction.  I measured those two resistors with the power on and the new numbers for both is 0.005.  Is that better?

John B

John B

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #40 on: March 25, 2018, 01:34:57 AM »
Steve,

I'm changing multimeters.  The one I was using has an ohm range of 2K to 2000K and the new meter goes from 200 to 2000K and the resistors measured 8.3.  I found a web site that gives the ohms for the color strips.  Bear with me.

Thanks,

John B

John B

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #41 on: March 25, 2018, 11:48:37 AM »
I put the chassis back into the console and I'm not getting any sound at all and in fact the stereo needle isn't working.  Would a radio from a Magnavox 1P3651 work with my console.  It looks similar.  I see it on Craigslist for $35.  Waiting to see if the radio in it works.  I'm getting frustrated with mine.

Hold everything.  I think I found a crack in the crossover capacitor.  It might be significant.

John B

John B

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #42 on: March 25, 2018, 12:58:55 PM »
Are these caps leaking?  Not sure what the board is but it looks to me something to do with radio?

John B

John B

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #43 on: March 25, 2018, 10:26:48 PM »
Disc Cap?  Looks inflated to me.  Connected to loudness pot.  The Craigslist deal fell through.  I was given the whole thing after my $10.00 offer but it really looked bad and it wouldn't fit into my trunk and it would probably have the same problems as mine even if the radio did work as it is still old.  I hope I'm not posting too much.

John B

electra225

  • Hero Member
  • *****
  • Posts: 2482
    • View Profile
Re: Magnavox Micromatic Model: 2ST647 New Needle - No Sound
« Reply #44 on: March 26, 2018, 12:14:05 AM »
That is not a disc cap.  It is a couplet.  A couplet is an early attempt at miniturization.  There are several resistors and capacitors encapsulated in that ceramic blob.  Leave it alone.  I don't know if any of the caps you are looking at are bad just by looking at them.  Generally speaking, any cap that leaks is bad and replacement is indicated.  I can't stress enough the importance of developing a directed series of tests to troubleshoot your stereo.  Guessing and throwing parts at it will not gain you anything.  Get your schematic out, learn to read it, then follow it, measuring and testing as you go.  It does not matter if you are working with tube or solid state, troubleshooting methods need to be followed.  That schematic is the road map that tells what voltages should be present, where, and how it flows thru the circuit.  Don't give up.  Toughing it out on one of your first jobs is how you learn.  We've all done that.  Good luck.
I don't need Google.  My wife says she knows everything.