Author Topic: Static through speakers on all settings  (Read 130 times)

Pizmo

  • Newbie
  • *
  • Posts: 18
    • View Profile
Static through speakers on all settings
« on: October 15, 2018, 01:44:37 PM »
Hello.

I have a problem that started a few weeks ago on my RCA VLT-49-S. There is a loud static/popping noise coming through both speakers on every setting.

The noise comes and goes at random and it isn't effected by changing the settings on any of the dials. It does it on all inputs. Turning the volume knob all the way up or down does not effect the volume of the noise. Also turning the balance all the way left or right doesn't affect the noise. It still comes equally through both speakers.

It also seems to be extremely random. Sometimes it will go days without making the noise. Other times it makes the noise constantly.

TC Chris

  • Hero Member
  • *****
  • Posts: 1385
    • View Profile
Re: Static through speakers on all settings
« Reply #1 on: October 16, 2018, 08:21:38 PM »
Well, what yo know is that the problem arises AFTER the volume control in the amplifier.  That will help you to track it down with the schematic.

Chris Campbell

Pizmo

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Static through speakers on all settings
« Reply #2 on: October 16, 2018, 09:01:33 PM »
I dont suppose you know where I could find a wiring diagram for this stereo

TC Chris

  • Hero Member
  • *****
  • Posts: 1385
    • View Profile
Re: Static through speakers on all settings
« Reply #3 on: October 16, 2018, 10:38:38 PM »
I usually do a Google search to see if I can find a free one.  Sometimes you'll have to buy a copy of a Sams Photofact.  Or you can ask here, and see of anybody has one.  In the very old, pre-internet days, if I couldn't find a Sams in the university's engineering library, I'd write to the manufacturer.  Montgomery Ward, GE, and Zenith all sent me schematics for 1930s radios. 

I loved having the univ. library available. Problem was, the photocopier cost 5 cents a page and at the time that was big money in my budget.  Let's see, lunch, or a new schematic?

Chris Campbell

Pizmo

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Static through speakers on all settings
« Reply #4 on: October 17, 2018, 01:18:42 PM »
I've tried googling my stereo and cannot find any relevant info on it. I also do not see any identifying labels on the amp. So I am not even sure what amp I have in this console.

If this was your stereo and you could not find any info on it where would you start in trying to diagnose the issue?

Motorola Minion

  • Hero Member
  • *****
  • Posts: 832
  • Southern Pennsylvania
    • View Profile
Re: Static through speakers on all settings
« Reply #5 on: October 17, 2018, 01:53:07 PM »
I had this problem on an early solid state Magnavox but I can look up your set in my Sams, and will post to uploads.

It simply required heat sinks on a pair of driver transistors, which feed the output driver transformer.

The first step I would take is to obtain some freeze spray, or component cooler. When the crackles start, selectively chill the suspect transistors and it will probably stop like mine did.
Tubes - Magical - Tubes

Dave

Maggie Man

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Static through speakers on all settings
« Reply #6 on: November 03, 2018, 08:58:04 AM »
I have a solid state Magnavox that does that in one channel. Only the right channel has a static, or hissing noise that doesn't change with the loudness control. The noise is similar to the noise between FM stations.